Custom style is not applied to empty package in Class diagram

0 votes
asked Nov 12, 2015 in Bug by bond007 (650 points)

The screenshot:

Screenshot

1 Answer

0 votes
answered Nov 13, 2015 by plantuml (184,620 points)

Hi,

Actually, "Database" has its own skinparams and does not share setting from "Package" one.

So you should use something like:

@startuml
skinparam database {
  border {
    color grey
    thickness 1
  }
  BackgroundColor yellow
  Font {
    Color LightGrey
    Size 14
  }
}

package "<size:18>styled</size>\nshould be styled" <<Database>> {
}

package "<size:18>styled2</size>\nshould be styled" <<Database>> {
class foo
}

@enduml

 

Does it make sense for you ?

...