Please provide a new command line parameter to output tikz without the latex preamble

0 votes
asked Feb 13, 2016 in Closed feature request by choppsv1 (150 points)

I'm trying to include UML diagrams in org mode beamer (latex) exported documents. The current -tlatex flag outputs a full latex file (i.e., documentclass, usepackage, begin{document} ...) all of those mess up my actual document that this tikz output is being included within.

Please can you provide a new command line parameter to output tikz without the latex preamble.

1 Answer

0 votes
answered Feb 15, 2016 by plantuml (188,280 points)
selected Jul 8 by Anthony-Gaudino
 
Best answer

In the last beta: https://dl.dropboxusercontent.com/u/13064071/plantuml.jar
we have added a -tlatex:nopreamble flag in the command line (and in the ANT task).

It has not been highly tested, but it seems to work fine.
Tell us if it's what you are expecting!

commented Feb 15, 2016 by choppsv1 (150 points)
Seems to work just fine. Thanks!
...