How to install newest Eclipse Plugin of PlantUML

0 votes
asked Jun 18, 2016 in Wanted features by anonymous
I have Eclipse Plugin of PlantUML version 7997.
 
I'd like to use newest version (plantuml.8042.jar) and newest syntax.
 
Can you tell how to install it?
 

2 Answers

0 votes
answered Jun 19, 2016 by plantuml (182,820 points)

It depends which version of Eclipse you are using.

Basially, to install the plugin, you must :

  • Go to Help/Software Update/Find and install... or Help/Install new software...

More info on http://plantuml.com/eclipse.html

 

commented Sep 29, 2016 by Mika (270 points)
Is http://plantuml.sourceforge.net/updatesitejuno/ supposed to work as an update site? There appears to be a single jar file under 1 kilobyte in size?

Also, adding that site to eclipse (4.5.1) doesn't seem to work.

The other site listed still has version 7997?
commented Sep 29, 2016 by Mika (270 points)
Looks like replacing plantuml.jar under the <eclipse_dir>/configuration/org.eclipse.osgi folder structure with the latest version (8047) worked after installing version 7997 from the eclipse update site.
0 votes
answered Sep 21 by anonymous
Use the following link as the update stie: http://hallvard.github.io/plantuml/
...