Can I use monospaced fonts as default setting?

0 votes
asked May 19, 2017 in To be sorted by anonymous
retagged May 22, 2017
I don’t feel like write ""monospace"" every time when using monospaced fonts.
Can I set any parameters at command or file?

1 Answer

0 votes
answered May 22, 2017 by plantuml (190,190 points)
Best answer

Yes, you can use -config flag in the command line. See

Hope this help!
commented May 23, 2017 by anonymous
Thanks for answer.

I'm using skinparam with [-config filepath] as you wrote.
I want to use monospace without escape.(not FontName parameter)
Is it in skinparam ?

I saw
Maybe no usage there.
commented May 23, 2017 by plantuml (190,190 points)
You can use "skinparam defaultFontName monospaced"

skinparam defaultFontName monospaced
alice -> bob : help
result :

So if you put "skinparam defaultFontName monospaced" in your config file, it should work.
commented May 24, 2017 by anonymous
It was work fine and very helpful.

I didn't understand parameter to set.
so, I thought defaultFontName is must set like SansSerif.

Thanks for your help!