Can I use monospaced fonts as default setting?

0 votes
asked May 19, 2017 in To be sorted by anonymous
retagged May 22, 2017
I don’t feel like write ""monospace"" every time when using monospaced fonts.
Can I set any parameters at command or file?

1 Answer

0 votes
answered May 22, 2017 by plantuml (183,480 points)
 
Best answer
Hello,

Yes, you can use -config flag in the command line. See http://plantuml.com/command-line

Hope this help!
commented May 23, 2017 by anonymous
Thanks for answer.

I'm using skinparam with [-config filepath] as you wrote.
I want to use monospace without escape.(not FontName parameter)
Is it in skinparam ?

I saw http://plantuml.com/skinparam
Maybe no usage there.
commented May 23, 2017 by plantuml (183,480 points)
You can use "skinparam defaultFontName monospaced"

@startuml
skinparam defaultFontName monospaced
alice -> bob : help
@enduml
result : http://www.plantuml.com/plantuml/uml/3SpB3O0W303GErDq0HVmO3XvT8S2DHBx8RJihs-0bprmnX9E_dOTE56WqOsBupID2uL0JCq7Lce9kLU2xO1Y1NPuY4VAfEqFFW00

So if you put "skinparam defaultFontName monospaced" in your config file, it should work.
commented May 24, 2017 by anonymous
It was work fine and very helpful.

I didn't understand parameter to set.
so, I thought defaultFontName is must set like SansSerif.

Thanks for your help!
...