A preprocessor condition, based on the current plantuml.jar version?

0 votes
asked May 24, 2017 in Wanted features by boshka (2,230 points)
edited May 24, 2017 by boshka
i'd like to differenciate iuml code based on the PlantUml version used. Is it possible?

such as:

!if %PLANTUML_VERSION% >= 1.2017.12
    <new code>
   <legacy code>

1 Answer

0 votes
answered May 29, 2017 by plantuml (144,190 points)

It's not possible in official release, but in last beta:


You can have:

title this is %PLANTUML_VERSION%
alice -> bob : hello
!if %PLANTUML_VERSION% > 1201713
alice -> bob : A
alice -> bob : B

Unfortunately, this is not working with "old" release.

Thanks for the suggestion!

commented May 30, 2017 by Serge Wenger Work (7,840 points)

Could you add !if in the PlantUML keyword file generated with -language?

commented May 30, 2017 by plantuml (144,190 points)
Sure, thanks for the remind ! :-)