update plantuml ,using at redmine

0 votes
asked Aug 9, 2017 in To be sorted by anonymous
edited Sep 7, 2017

I'm using plantuml.8042.jar with redmine+wiki_extrnal_filter. It's works fine.

I tried to update to plantuml.1.2017.15.jar (only replace symbolic link to /usr/bin/plantuml),and it was not works fine.

so, I tried another versions.

  • plantuml.8059.jar - fine.
  • plantuml.2017.08.jar - not fine.

Did something change between these versions?

 

[P.S.]

I want to generate SVG+XML images.

Execution command should be :

/usr/lib/jvm/java/bin/java -jar /usr/share/java/plantuml.jar -tsvg -config "/var/lib/redmine/config/umlcolor.cfg" "$@"

 

commented Feb 18 by Anthony-Gaudino (7,790 points)
Can you please better describe your issue, it's a bit hard to understand your problem.
commented Feb 19 by anonymous
Thanks for your reply.
And I'm sorry, I forgot details ...

I want cancel this question,and ask again when remembered.
commented Jul 4 by anonymous

I remembered.

I have 2 symlinks at /usr/share/java.

  • plantuml.jar -> plantuml.8059.jar
  • plantuml_latest.jar -> plantuml.1.2018.8.jar

I execute follows from redmine plugin.

  • /usr/bin/plantuml_svg

#!/bin/bash

. /usr/share/java-utils/java-functions

set_javacmd

export LANG=ja_JP.UTF-8; $JAVACMD $BASE_FLAGS -jar /usr/share/java/plantuml.jar -tsvg -config "/var/lib/redmine/config/umlcolor.cfg" "$@"

  • /usr/bin/plantuml_latest_svg

#!/bin/bash

. /usr/share/java-utils/java-functions

set_javacmd

export LANG=ja_JP.UTF-8; $JAVACMD $BASE_FLAGS -jar /usr/share/java/plantuml_latest.jar -tsvg -config "/var/lib/redmine/config/umlcolor.cfg" "$@"

plantuml_svg is works fine, but plantuml_latest_svg is not.

{{plantuml_svg
@startuml
start
:this is test]
stop
@enduml
}}

{{plantuml_latest_svg
@startuml
start
:this is test]
stop
@enduml
}}

Is there any solution?

note

If without -tsvg option, both work fine.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register.
...