Cannot recognize included file in config file

0 votes
asked Nov 6 in Wanted features by tatevik (180 points)
I have a config file in which is included another file,When I am running with config file from command line the included file isn't recognized but when I include my config file into my plantuml script and ther I am runing only plantuml script the included file is read. How can I make my included file in config file recognized when running in command line?

1 Answer

0 votes
answered Nov 6 by plantuml (134,510 points)

Which version of PlantUML are you using ?

For us, the following example is working:


File config.txt:
skinparam handwritten true

File test.txt:
@startuml
alice -> bob : ok
@enduml

java -jar plantuml.jar -config config.txt test.txt

Can you test this on your configuration ?

Thanks,

commented Nov 6 by tatevik (180 points)
Thanks for answer.
I use PlantUML version 1.2017.16
This example works for me but I have another situation.
For example int config.txt we have included file another_config.txt(where all skinparams are written) and when I run ```java -jar plantuml.jar -config config.txt test.txt``` command I am getting error :
 Error line 0 in file: C:\path\to\test.txt
Some diagram description contains errors
But when I include config.txt in text.txt and simply run java -jar plantuml.jar test.txt all files are included successfully. So I need to know How can I run my config file from command line without adding it to my test.txt
commented Nov 7 by plantuml (134,510 points)
Ok, thanks for the explanation.
This should work with last beta (beta22)
http://beta.plantuml.net/plantuml.jar
However we made some deep changes here, so please tell us if you find regressions!
Thanks
commented Nov 7 by tatevik (180 points)
Thanks :)
Now it works. But I woulb prefer to see this solution also in stable version.
commented Nov 7 by plantuml (134,510 points)
Sure, we will publish an official release in a couple of weeks.
...