Set LegendBorderThickness to 0?

0 votes
asked Feb 15 in Closed feature request by bx
I would like to have a table in the legend with no borders, when I set LegendBorderThickness to zero, it defaults to 1. Is it possible to hide the Legend Border altogether? Or at least insert a table inside it with a hidden border?

Thank you!

2 Answers

0 votes
answered Feb 18 by plantuml (176,140 points)
selected Mar 21 by Anthony-Gaudino
 
Best answer

We like the idea of "BorderThickness" to zero (rather than using "transparent" color).

So with last beta http://beta.plantuml.net/plantuml.jar , you can have:

@startuml
skinparam LegendBorderThickness 0
Bob -> Alice : hello
legend
this is a legend
endlegend
@enduml

Setting thickness to zero probably does not work in other situation, so we are interested in feedback!

Thanks,

commented Feb 18 by bx
Two questions:

1. Are you able to update

http://www.plantuml.com/plantuml/uml/SyfFKj2rKt3CoKnELR1Io4ZDoSa70000

so that I can test it?

2. I'm running the .war from Java EE Eclipse so I'm not sure how to implement the web server without a .war file (if you can tell me how to implement with .jar that would be helpful as importing .war each time is a bit cumbersome :)

Thanks!
commented Feb 19 by plantuml (176,140 points)
The beta is online now http://www.plantuml.com/plantuml/uml/SoWkIImgAStDuIhEpimhI2nAp5NmIKrFpKjnoYzAIIqAoSXCpivBBIvMCE1ooazIqBLJSCp9J4vLi5B8ICt9oUVA0IlcAid8B5O0eaG5g00GGraEG09e0G00

Not sure to understand point 2... However, you can change plantuml.jar file inside plantuml.war file using any ZIP editor. Is this what you are looking for ?
commented Feb 19 by bx
Thanks for the quick reply.

1. The legend border 0 works, but before the border of a table within the legend had the same border as the legend, which now no longer seems to be the case? I don't mind as much about the legend border as much as I want to be able to have a table (within the legend) that has no border.

For example, I want to be able to remove the table lines from the following table:

http://www.plantuml.com/plantuml/uml/PP1TQy8m68NlyoiEx6Q3pLYPOojEdDg1q0rcwvNp8cqoBSqNIKeH_F6Bkhj1u3pm9kSz9pCVc0kTaiItZRRCCOLSx8NcSrQtUsSwpHT66eSRsUmFuIYaD3tm_xfnNBZoqDIj5jvZI8Yy352P48mYasgwphusgtMsnAhCFee9hQQ4d5w18WWBd6d9WhZI9rD_L0GMEd_blD5j9782aa4I2IZdoujkjuSGh4yfxVj-m3oFPr0RHPcrdd9JTqheu6aJXF8qUNaQuss-sEtYuqbzRfXMCbQU0Z7fHhVQzFfY7DV56jSoXDJHH3Zy67EMRvqp7x2nF0RdAV0kAjSnTqGoliTec3m33p7hA7qSmYhWDYlAEpABLl7FVm40

Any suggestions?

2. Substituting the .jar in the .war is a useful tip. Once the .war has already been imported, is there any way to update it to a new .jar version without having to import a .war (in Java EE Eclipse)  again?

Thanks!
commented Feb 19 by plantuml (176,140 points)
About table, the real difficulty is to find the right syntax.
Up to now, we just support "Creole" table (see http://www.wikicreole.org/wiki/Tables ) which are very simple.
Maybe it's time to add some more complex tables.
Here is a discussion about possible syntax : https://meta.wikimedia.org/wiki/Wiki_table_markup_discussion_history

We don't want to define yet another syntax.
It would be nice if you could search among existing wiki syntaxes, which would be the more flexible.
It seems that Wikipedia syntax gives a lot of possibilities ( https://en.wikipedia.org/wiki/Help:Table )

Do you know better ones ?
commented Feb 20 by bx
I can take a look. But in the short-term, if I set legendborderthickness to 2, the table thickness increases as well, why does the table thickness no longer match once the legend thickness is set to 0?

The current syntax seems fine, it is just a background setting of the table I am trying to change, and that setting seems changeable as it gets thicker but won't go to zero, so maybe there is an easier solution that adopting much more complex table syntax?
0 votes
answered Feb 16 by Serge Wenger Work (9,550 points)

You can try:

@startuml
skinparam LegendBorderColor transparent
skinparam LegendBackgroundColor transparent
Bob -> Alice : hello
legend
{{
salt
{
aaa | bbbb
zzzzzzzzzz | cccccc
}
}}
endlegend
@enduml

commented Feb 18 by bx
Thanks for your quick reply!

The transparency seems to work in your code regardless of the skinparam settings. I'm using Creole formatting in my table which doesn't seem to work with salt. I.e. here is my code:

legend bottom
<b>REQUIRED ITEMS</b>

|=  Step  |=  Date  |=  Name  |=  Status  |=  Link  |
|  1.1  |  TBD  |  [[https://link.com/apps/documents/items/1965 (D1965)]]  |<color:black>  <b>Unknown  |   |
|  1.2  |  TBD  |  [[https://link.com/apps/documents/items/2064 (D2064)]]  |<color:darkturquoise>  <b>Complete  |  [[https://drive.google.com/open?id=jkahfs98723498723 View]]  |
endlegend

When I use salt for that, it comes out very distorted. Any other suggestions or workarounds?

Thanks!
commented Feb 19 by bx
That link still shows the table lines, my goal is not to see any table border or lines. Sorry if I wasn't clear.
commented Feb 19 by Serge Wenger Work (9,550 points)
@startuml
skinparam LegendBorderColor transparent
skinparam LegendBackgroundColor transparent
Bob -> Alice : hello
legend bottom
<b>REQUIRED ITEMS</b>
{{
salt
{
| Step | Date | Name |Status | Link
|  1.1  |  TBD  |  ([[https://link.com/apps/documents/items/1965 D1965)]]  |<color:black>  <b>Unknown
|  1.2  |  TBD  |  ([[https://link.com/apps/documents/items/2064 D2064)]]  |<color:darkturquoise>  <b>Complete | _[[https://drive.google.com/open?id=jkahfs98723498723 View]]
}
}}
endlegend
@enduml
commented Feb 19 by bx
That is closer, thanks! Still a bit strange with the syntax having to have leading characters before the links. I will want to try to new Beta first and if that doesn't work I can consider this syntax. Thank you.
commented Mar 16 by Anthony-Gaudino (7,630 points)
I remember trying to set the border to zero in many cases without success.

Good to know it's being implemented.
...