Break in while loop renders incorrectly

0 votes
asked Feb 26 in Closed feature request by nulldev (160 points)
There is an issue where break statements inside while loops do not render correctly. In the following example, I expect "TestNode" to be linked to "Clean up" but instead it seems to just be detached.

http://www.plantuml.com/plantuml/uml/HSun3i8m30NGtQVmc5wX5Q8IB2nCN20bloGYJQhQ5UBsE32msDB_Jx97KR_flcHwnPJXBiAU3pmTEqx2xWtfYBa_LvQwG6CgZy62D3SPJDvDQaJvsnj4hpMWkMc3Vzf65h0hjG6Ka6Qo-RtuI_jJXY-yhmE9rfL6g-sf3m00

P.S. Thanks for writing this amazing program! The diagrams it makes are much more beautiful and well organized compared to other generators!

1 Answer

+1 vote
answered Feb 27 by plantuml (184,620 points)
selected Feb 27 by nulldev
 
Best answer
Thanks for your report.

The fact is that this "break" feature is still beta and was only implemented for "repeat" loop (and not "while" loop).

Anyway, adding this feature to while loop was not so hard, so we did it in last beta http://beta.plantuml.net/plantuml.jar

We've upgraded the online server so your example is working now (use ctrl-F5 to force cache reload) http://www.plantuml.com/plantuml/uml/HSun3i8m30NGtQVmc5wX5Q8IB2nCN20bloGYJQhQLSNjSLXOREdxIT-ZgDzqNp8TCMMucx3d4q_dZfEm-q0wOkwlbQKkq9ZAQx0WpKq6aq-J6b7-zW7HUmreRjhWtxQH1UnARG0bf9bi_XgflsJumliwa6XTQRIB_VC5

However, do not expect too much on this feature. It will work on simple case, but will fail on complex ones.

So we are interested in feedback!
commented Feb 27 by nulldev (160 points)
That's perfect, thanks for your help! I'll notify you if I find any other bugs.
...