EntityFont* skinparams don't appear to work in sequence diagram

0 votes
asked Apr 20 in Question / help by pudge (190 points)
edited Apr 20 by pudge

I've set the EntityBackgroundColor and EntityBorderColor successfully in my sequence diagrams. However, when I set EntityFontStyle, EntityFontSize, and EntityFontColor they have no effect on the diagram. Is this a bug or am I missing something? I'm using version 1.2018.3.

E.g.

@startuml

skinparam Entity {
   BorderColor #c8c8c8
   BackgroundColor #5b9bd5
   FontStyle bold
   FontSize 14
   FontColor #5b9bd5
}

skinparam Sequence {
   ParticipantBorderColor #c8c8c8
   ParticipantBackgroundColor #5b9bd5
   ParticipantFontStyle bold
   ParticipantFontSize 14
   ParticipantFontColor #ffffff
}

participant Alice
entity Bob

Alice -> Bob: call 1
Bob --> Alice: response

Alice -> Bob: call 2
Alice <-- Bob: response
@enduml

Same is true for Control.

2 Answers

0 votes
answered Apr 23 by plantuml (184,600 points)
selected Apr 24 by pudge
 
Best answer
Thanks for the report.

It's indeed a bug and should be solved in last beta http://beta.plantuml.net/plantuml.jar

Tell us if you find other issues.

Regards,
0 votes
answered Apr 21 by pudge (190 points)

For some reason, the Entity and Control font parameters are attached to the Actor skinparam, which doesn't make a whole lot of sense to me. Is this a bug or is it intentional?

E.g.

@startuml
skinparam Actor {
   FontStyle bold
   FontSize 14
   FontColor #5b9bd5
}

skinparam Entity {
   BorderColor #c8c8c8
   BackgroundColor #5b9bd5
}

skinparam Sequence {
   ParticipantBorderColor #c8c8c8
   ParticipantBackgroundColor #5b9bd5
   ParticipantFontStyle bold
   ParticipantFontSize 14
   ParticipantFontColor #ffffff
}

participant Alice
entity Bob

Alice -> Bob: call 1
Bob --> Alice: response

Alice -> Bob: call 2
Alice <-- Bob: response

@enduml
...