allow mixing?

0 votes
asked Aug 16 in Wanted features by valexiev (790 points)

I want to make an example of all shape types available in puml (I got this with the -language option).

It gives me an error and says "Enable 'allow mixing'" (see the URL above). But when I put these words in the beginning, then it says "syntax error".

1 Answer

+1 vote
answered Aug 17 by mgrol (2,560 points)

Hi,

because you are missing the "_" in your allow_mixing

@startuml
allow_mixing
abstract Abstract
actor Actor
@enduml

Additionally, in your linked image there is no allow_mixing. Anyhow, the above sample will result in this picture 

BR,

Michael

commented Aug 17 by valexiev (790 points)
Hi! I thought I answered this but obviously no. The excellent tagging feature on this forum told me to go look at other answers, so I figured it out.

Still, puml needs to be fixed to mention "allow_fixing" in the error message (not "allow mixing"), and "-language" should print out this new option.
commented Aug 20 by mgrol (2,560 points)
It surely does if you take a look here
http://www.plantuml.com/plantuml/png/SoWkIImgAStDuKfCAYufIamkKN24ChY0EBz8mH54SZcavgK0LG40 Your screenshot is somehow cut of.
For the -language take you are completely right. It should be in there.
commented Aug 20 by valexiev (790 points)
"screenshot is somehow cut off": in this case of error, puml calculates the needed image height a couple of pixels short, which lead to my confusion. I think it would be best to also print out the errors to STDERR, in addition to the output image.

Do you know how to "reopen" this discussion, so the creator can notice and track the two buggies? To recap, they are:
- the "-language" option should print out "allow_mixing"
- print out errors to STDERR, in addition to the output image
commented Aug 20 by mgrol (2,560 points)
Hey,

for your first bullet point, you can find the ticket here, just upvote it: http://forum.plantuml.net/7095
for your second point: You might need to open a new ticket or send a PN to plantuml.
...