Set Background Color of Latex Math Entries

0 votes
asked Sep 18 in Bug by Stas

Hello, I use the Activity Diagram with the new syntax and I have the following problem: when set the style to monochrome (or change the color of the node background) the math equations in <latex></latex> are still on a yellow background.

Is there an option to set it with skinparam for the whole document? The ideal world would be if the equation were on a transparent background... 

I am using PlantUML version 1.2018.10

Thanks for the great program.

2 Answers

0 votes
answered Sep 18 by plantuml (182,940 points)

Thanks for the report. This issue is now fixed in last beta http://beta.plantuml.net/plantuml.jar

The following example is now working:

@startuml
skinparam monochrome true
:<math>int_0^1f(x)dx</math>;
:<math>x^2+y_1+z_12^34</math>;
note right
<math>d/dxf(x)=lim_(h->0)(f(x+h)-f(x))/h</math>
<latex>P(y|\mathbf{x}) \mbox{ or } f(\mathbf{x})+\epsilon</latex>
end note
@enduml

Tell us if it's not working for you !

0 votes
answered Sep 19 by Stas

Hello, thanks, the color is working now. However, a better option would be transparent background. Consider this example:

@startuml
skinparam monochrome true
start
while (<latex>j \leq j_{\max}</latex>) is (<latex>\textrm{true}</latex>)
:test;
endwhile (<latex>\textrm{false}</latex>)
end 
@enduml 

This produces a png file where the true and false keywords have a gray background and overlay other elements. 

Sorry, I cannot find an option to upload an image.

commented Sep 19 by plantuml (182,940 points)
Ok, last beta http://beta.plantuml.net/plantuml.jar works better with your example
Is it ok for you ?
...