Latest PlantUML (Version 1.2018.11) cannot !include with pipe

+2 votes
asked Oct 9, 2018 in Bug by jebbs (220 points)

According to my user feedback:

https://github.com/qjebbs/vscode-plantuml/issues/150

Latest PlantUML (Version 1.2018.11) cannot !include with pipe, neither "-Duser.dir=path/to/dir", nor set the CWD of the process. Older version works good for both.

Please have a look.

Thanks!

1 Answer

0 votes
answered Oct 9, 2018 by plantuml (201,100 points)
selected Oct 10, 2018 by jebbs
 
Best answer
Thanks for the feedback.

We have indeed changed the whole preprocessor implementation with version 1.2018.11

The issue with pipe option and !include should be fixed in last beta http://beta.plantuml.net/plantuml.jar

Tell us if it's not working for you.
commented Oct 10, 2018 by jebbs (220 points)
Yes, it's fixed, thank you for quick response!
commented Oct 12, 2018 by Meo (1,040 points)
@plantuml

I was using FileSystem.getInstance().setCurrentDir(baseDir);  - before rendering and syntax checking, it no longer works.
So I changed it to  System.setProperty("plantuml.include.path", baseDir.getAbsolutePath());.
- I hope that's intended?
 (using the beta)
...