Running in background - disable di=splay of the icon

0 votes
asked Dec 13, 2018 in Question / help by rkrug (310 points)
Hi

maybe it is a java issue - would it be possible to add an option, that the icon / window of Java is not displayed when running plantuml? I have a document which generates many plantuml files, and it is extremely difficult to work somewhere else while compiling as the window from Java is regularly activated.

Thanks,

Rainer

1 Answer

0 votes
answered Dec 13, 2018 by plantuml (190,670 points)
Which version of PlantUML are you using ?

There was an old issue (detail http://forum.plantuml.net/5403/popup-icon-disrupts-gui-use-grabbing-keyboard-window-focus ) but it should be fixed now.

Maybe you should also try -Djava.awt.headless=true option
commented Dec 13, 2018 by rkrug (310 points)
Your newest beta.

I looked at the thread and added "-Djava.awt.headless=true -splash:no" as default options - working now - thanks.

By the way: I have at https://github.com/rkrug/plantuml a package written to use plantuml from R.

You can either supply the plantuml code or use it to document your R objects as class diagrams. It is in beta, but I am using it in production. So please feel free to add it to your section of programs supporting plantuml. Would you need any further info about the package?
...