Activity Beta - labelling an arrow that enters a partition, label is never shown - Bug?

0 votes
asked Feb 10, 2015 in Bug by anonymous
Example below. The label "image" never appears. Tried a few other positions for the command, either side of the partition command, and I think also exiting the partition.

Version: PlantUML version 8019 (Mon Feb 02 17:36:46 GMT 2015)
(GPL source distribution)
Java(TM) SE Runtime Environment
Java HotSpot(TM) 64-Bit Server VM
Windows 7

The environment variable GRAPHVIZ_DOT has not been set
Dot executable is c:\Program Files (x86)\Graphviz2.38\bin\dot.exe
Dot version: dot - graphviz version 2.38.0 (20140413.2041)
Installation seems OK. File generation OK

Example: @startuml
'Using an Activity Diagram

'This is the new syntax (from V7947)
'It doesn't seem to offer as many layout controls, and there
'are a couple of bugs preventing correct content.
'but the text is clearer, and it allows more flow control.
'GR ADVICE: use the old format.

title Activity Diagram PlantUML New Syntax

'PlantUML bug - Arrow label across partition is never shown
partition OpticalFlow {
split again
->Info from Car;
'PlantUML bug - Arrow label is placed after the end split. (separately reported)
end split


1 Answer

0 votes
answered Feb 10, 2015 by plantuml (149,180 points)

Thanks for the report.

The following beta should solve this (there are still some drawing artifacts).

Some bugs are probably still there about labels on arrow.
Do not hesitate to de some more feedback...

Thanks again for your tests!