!Include won´t work

0 votes
asked Nov 6, 2019 in Bug by kennyloeffler (160 points)

I tried to include a stylesheet in Plantuml like this

!include style.iuml

But it won´t really work, i tried a lot of different variatons but it seems like there is a problem. Also other people have the sam problem with the " !include " command.

Is there an alternative command to include external files / stylesheets?

1 Answer

0 votes
answered Dec 18, 2019 by George Liou (240 points)
edited Dec 18, 2019 by George Liou

I also bumped into similar case. My temporal solution is to move files to a folder which doesn't have any non-ASCII character in the full path.


Full Case Study:

The bug under the following environment had been tested and reproduced.

1. Runing Atom or VSCode with "Markdown Preview Enhanced" plugin  under  Microsoft Windows 1909

2. Suppose Test.md is the file which contains the following script


!include style.iuml


Test.md and style.iuml are under the same folder X 

3. The full path of folder X contains non-ascii characters, like "工廠".


Error message would be similar to:

[From string (line 2) ]

!include style.iuml
cannot include style.iuml


If I move Test.md and style.iuml to another folder, for example

R:\Factory X\Test.md
R:\Factory X\style.iuml

Then the problem resolved. What's interesting is even white space is supported in folder path, but non-ASCII ones are just out of scope.