Diagram Not Generating - Error on Line 5 - Line 5 is Blank

0 votes
asked Feb 26 in Question / help by Logan

Hello! I have no idea why this is happening. Would love to hear where I'm being a dingus

Steps to Reproduce

  1. brew install graphviz
  2. brew install plantuml
  3. plantuml filename.plantuml

Output

Error line 5 in file: /Users/lknecht/Repositories/FAUST_Nextflow/documentation/faust_data_flow/global_faust_structure.plantuml
Some diagram description contains errors

Verbose Output

╰─$ plantuml global_faust_structure.plantuml -v                                                                                                                                                                                           200 ↵
(0.000 - 258 Mo) 252 Mo - PlantUML Version 1.2020.01
(0.012 - 258 Mo) 252 Mo - GraphicsEnvironment.isHeadless() true
(0.012 - 258 Mo) 252 Mo - Forcing -Djava.awt.headless=true
(0.012 - 258 Mo) 252 Mo - java.awt.headless set as true
(0.012 - 258 Mo) 252 Mo - Forcing resource load on OpenJdk
(0.756 - 258 Mo) 251 Mo - Found 1 files
(0.756 - 258 Mo) 251 Mo - Working on /Users/lknecht/Repositories/FAUST_Nextflow/documentation/faust_data_flow/global_faust_structure.plantuml
(0.770 - 258 Mo) 251 Mo - Setting current dir: .
(0.770 - 258 Mo) 251 Mo - Setting current dir: /Users/lknecht/Repositories/FAUST_Nextflow/documentation/faust_data_flow
(0.770 - 258 Mo) 251 Mo - Using default charset
(0.774 - 258 Mo) 251 Mo - Reading from global_faust_structure.plantuml
(0.817 - 258 Mo) 248 Mo - Reading file: global_faust_structure.plantuml
(0.832 - 258 Mo) 247 Mo - Creating file: /Users/lknecht/Repositories/FAUST_Nextflow/documentation/faust_data_flow/global_faust_structure.png
(0.941 - 258 Mo) 244 Mo - Creating image 536x309
(0.962 - 258 Mo) 243 Mo - Ok for com.sun.imageio.plugins.png.PNGMetadata
(0.999 - 258 Mo) 241 Mo - Number of image(s): 1
Error line 5 in file: /Users/lknecht/Repositories/FAUST_Nextflow/documentation/faust_data_flow/global_faust_structure.plantuml
Some diagram description contains errors

Code

@startuml
top to bottom direction
hide circle
hide members

 

!global input_color = #008000 
!global internal_requirement_color = #ff004d
!global output_color = #0091ff
!global adhoc_parameter_color = #ff5900
!global default_logic_color = default_logic_color


@enduml

2 Answers

0 votes
answered Feb 26 by anonymous
 
Best answer

The issue was the color variables. They need to be enclosed in double quotes like this.

@startuml
top to bottom direction
hide circle
hide members

!global input_color = "#008000"
!global internal_requirement_color = "#ff004d"
!global output_color = "#0091ff"
!global adhoc_parameter_color = "#ff5900"
!global default_logic_color = "#000000"

@enduml

0 votes
answered Feb 26 by plantuml (226,400 points)

Is it working when you add an element ?

Like in :

@startuml
top to bottom direction
hide circle
hide members

!global input_color = #008000
!global internal_requirement_color = #ff004d
!global output_color = #0091ff
!global adhoc_parameter_color = #ff5900
!global default_logic_color = default_logic_color

class foo
@enduml

...