Problems when running the plantuml.war file on Tomcat 7 in Synology

0 votes
asked Mar 25, 2020 in Question / help by Aj

I have a Synology NAS (DS718+) running version 'DSM 6.2.2-24922 Update 4'

I have installed the Java8 package and Tomcat 7 package.

Then I downloaded and copied the plantuml.war file to the `/var/packages/Tomcat7/target/src/webapps` folder.

I am able to see the plantuml home page.

When I click on the 'View as SVG' (http://MY-SYNOLOGY-IP/plantuml/svg/SyfFKj2rKt3CoKnELR1Io4ZDoSa70000) is get the following error.

I get the same error when I try to access the 'png' image.

I don't get this error when I run Tomcat 7 and add plantuml.war on my mac.

Why am I getting this error when I run it on Synology? and How do I fix this?

1 Answer

0 votes
answered Mar 25, 2020 by plantuml (265,020 points)
Well, please check in log files.

There must be some more specific error messages.

It's difficult to find what's going one without further information.

commented Mar 25, 2020 by Aj
I have looked at the tomcat logging facility, but I am not able to figure out which logger to setup. Can you help with that?