Does V1.2020.13 work with the PDF dependencies zip file?

0 votes
asked Jun 19 in Question / help by anonymous
Hello. Not sure if this is a bug but having upgraded to V1.2020.13, exporting an activity diagram as a PDF throws an error and no file is generated. Using the same diagram and dependencies from http://beta.plantuml.net/batikAndFop.zip works okay with the V1.2020.08 jar.

Test code:

@startuml
start
:Hello World;
stop
@enduml

I've set the new PLANTUML_SECURITY_PROFILE as explicitly LEGACY and tried using the latest versions of the dependencies in the zip file but no joy. Any help would be appreciated. Thanks.

1 Answer

0 votes
answered Jun 19 by plantuml (226,400 points)
This is indeed a regression caused by our recent change about security. Sorry about that!

It should be ok with last beta http://beta.plantuml.net/plantuml.jar

Tell us if it's not working for you!
commented Jun 19 by anonymous
Many thanks for the quick fix and reply - I can confirm that the beta jar resolves the issue and works with the existing dependencies bundle. Cheers!
commented Jun 24 by Steven Mileham
I thought I'd gone mad last week when I couldn't get this to work.  I literally spent an hour trying to get the class path to recognise the library files!  Just tried in .14 and it seems fine now.

So glad it wasn't just me!

Thanks for the fix.
...