Spurious JAVA output blocking sphinx

0 votes
asked Mar 3, 2023 in Question / help by anonymous


When I call from bash/powershell/cmd on Windows:

java -jar plantuml.jar test.txt

I got the following on stdout:

[2023-03-03T17:17:14.176] [INFO] ThreadId: 1 ThreadName: main JAVA BRIDGE CONSTRUCTOR.
[2023-03-03T17:17:14.176] [INFO] ThreadId: 1 ThreadName: main os.arch: x86
[2023-03-03T17:17:14.176] [INFO] ThreadId: 1 ThreadName: main LOADING lib: Microsoft.Flow.RPA.Desktop.UIAutomation.Java.Bridge.Native
Dll Process Attached
[2023-03-03T17:17:14.176] [INFO] ThreadId: 1 ThreadName: main >>> Adding listener.
[2023-03-03T17:17:14.191] [INFO] ThreadId: 1 ThreadName: main windows.length: 0
[2023-03-03T17:17:14.191] [INFO] ThreadId: 16 ThreadName: Thread-4 NamedPipe Server is created
[2023-03-03T17:17:14.191] [INFO] ThreadId: 1 ThreadName: main Java Bridge Initialization completed successfully.
Dll Process Detach

How to get rid of these messages? I'm not enough fluent with Java environment.

More critical, in combination with sphinx, these lines appear inside the PNG....

I'm running:

java version "1.8.0_361"
Java(TM) SE Runtime Environment (build 1.8.0_361-b09)
Java HotSpot(TM) Client VM (build 25.361-b09, mixed mode, sharing)

on Windows 11.

1 Answer

0 votes
answered Mar 3, 2023 by plantuml (295,000 points)
This is very weird: those logs are not produced by our library.

I have no idea of where they could come from.

Maybe the following link may help you: https://stackoverflow.com/questions/71515701/stop-javax-swing-joptionpane-from-printing-log-to-the-output
commented Mar 6, 2023 by anonymous
Thanks for your quick answer!

In the mean time, I reinstalled java et now it works perfectly.... pretty strange. but my problem is now "solved".