-tutxt switch does not produce unicode but simple ascii

0 votes
asked Apr 17, 2015 in Bug by anonymous


Tried the simple uml file below with the -tutxt switch. It produces an ascii file, not a unicode one. Tried -utxt also but no luck.

$ java -jar plantuml.jar -version
PlantUML version 8022 (Tue Apr 07 19:54:02 CEST 2015)
(GPL source distribution)
OpenJDK Runtime Environment
OpenJDK 64-Bit Server VM

The environment variable GRAPHVIZ_DOT has not been set
Dot executable is /usr/bin/dot
Dot version: dot - graphviz version 2.38.0 (20140413.2041)
Installation seems OK. File generation OK
$ java -version
java version "1.7.0_65"
OpenJDK Runtime Environment (IcedTea 2.5.3) (7u71-2.5.3-0ubuntu1)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)
$ cat test.uml
class Model {
-map<string, data>
$ java -jar plantuml.jar test.uml -tutxt
$ cat test.utxt
|Model             |
|-map<string, data>|
|+operator[]       |
$ file test.utxt
test.utxt: ASCII text


Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:

[Antispam2 Feature: please please wait 1 or 2 minutes (this message will disappear) before pressing the button otherwise it will fail](--------)
To avoid this verification in future, please log in or register.