Please provide skinparam shadowing false for all elements individually

0 votes
asked Jan 17, 2017 in Closed feature request by anonymous

Please provide skinparam shadowing false for all elements individually.

Example:

skinparam componentShadowing false
skinparam rectangleShadowing false
skinparam actorShadowing false
skinparam databaseShadowing false

1 Answer

+1 vote
answered Jan 17, 2017 by plantuml (201,140 points)
selected Apr 24, 2018 by Anthony-Gaudino
 
Best answer

Ok, with last beta https://dl.dropboxusercontent.com/u/13064071/plantuml.jar

You can have:

@startuml
skinparam componentShadowing false
skinparam rectangleShadowing false
skinparam actorShadowing false
skinparam databaseShadowing false
actor actor
component component
rectangle rectangle
database database
@enduml

Is this what you are expecting ?
Thanks

commented Jan 26, 2017 by anonymous
Thanks a lot !
commented Jun 13, 2018 by anoff
Having nested content within a rectangle seems to turn shadowing back on. Is this expected behavior or a bug?

@startuml
skinparam componentShadowing false
skinparam rectangleShadowing false
skinparam actorShadowing false
skinparam databaseShadowing false
actor actor
component component
rectangle rectangle
database database

rectangle r2 {
  node node
}
@enduml
commented Jun 13, 2018 by plantuml (201,140 points)
Thanks for the feedback.
It's indeed a bug.
It should be fixed in last beta http://beta.plantuml.net/plantuml.jar

Regards,
commented Mar 8 by anoff (230 points)
Should this feature be enabled in all diagram types? Does not work in sequence diagrams

```
@startuml
skinparam participant {
  Bordercolor none
  Backgroundcolor none
  Shadowing false
}
actor Bob #red
' The only difference between actor
'and participant is the drawing
participant "<size:30><&key>" as L

Alice->Bob: Authentication Request
Bob->Alice: Authentication Response
Bob->L: Log transaction
@enduml
```
...