I cannot use exported xmi file in StarUml 2.

0 votes
asked Jan 30, 2017 in Wanted features by bprog (120 points)

I  used -xmi:star flag to generate xmi file from my class diagram.

I used StarUML 2, http://staruml.io/ to import the xmi file, and It does not work, it shows me just an empty XMIImported model.

Is this a bug or I did something incorect?

1 Answer

0 votes
answered Jan 31, 2017 by plantuml (247,300 points)
edited Jan 31, 2017 by plantuml
Thanks for the feedback.

You did nothing wrong, we have tested import with StarUML, not yet with StarUML 2.

Anyway we will do some investigations and tests with StarUML 2  and post results here.

Regards,
commented Feb 13, 2019 by VaclavT
Hello,
I've tried to export xmi file (with flag -xmi:star) and then to import it into latest version of StarUML (currently 3.0.2) and it failed..  For version StarUML2 mentioned in previous post I could not get XMI extension working.
Are there plans to restore support for that exporting functionality ?

Thank you
VaclavT
commented Jun 29, 2020 by valexiev (1,100 points)
Same here. I tried with both options `-txmi:star` and `-txmi:argo` and neither file shows anything in StarUml 3.2.2 (haven't tried with ArgoUML).

@plantuml Do you have plans to fix this?
...