maxAsciiMessageLength dosn't work

0 votes
asked Feb 10, 2019 in Closed feature request by wro02922 (760 points)

Hi,
It looks that skinparam maxAsciiMessageLength dosn't work. Therefore, I need to use manual line brake '\n'.

@startuml
skinparam maxAsciiMessageLength 50
participant a
participant b
a -> b :0123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789
a -> b :return 0123456789012345678901234567890123456789012345678\n901234567890123456789012345678901234567890123456789
@enduml

commented Oct 5 by wro02922 (760 points)
is it possible to introduce maxAsciiMessageLength in sequence diagram?

1 Answer

0 votes
answered Oct 6 by plantuml (232,720 points)
selected Oct 6 by wro02922
 
Best answer

All those settings are not very consistent, and we should probably implement something easier to understand, but there is a maxMessageSize setting :

@startuml
skinparam maxMessageSize 50
participant a
participant b
a -> b :this is a very long message on several words
a -> b :0123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789
a -> b :return 0123456789012345678901234567890123456789012345678\n901234567890123456789012345678901234567890123456789
@enduml
commented Oct 6 by wro02922 (760 points)
Many thanks. The maxMessageSize is also fine to me.
...