Both background color and hyperlink attributes do not work for activity block in activity diagram beta

0 votes
asked Jun 10, 2019 in Question / help by Sarunas
Hi Folks,

I am using dot-graphviz 2.26.0 and I get error when trying to specify both color and hyperlink for a activity block:

@startuml

#ff8822 :color works;
[[http://plantuml.com/sequence]]:hyperlink works;
#ff8822 [[http://plantuml.com/sequence]]:both fail;

@enduml

Is there a way how I could get it working, or this is some kind of bug ?

Many Thanks

2 Answers

+1 vote
answered Jun 11, 2019 by plantuml (226,400 points)
commented Jun 11, 2019 by anonymous
Thanks very much, plantuml :) It worked out.

Maybe you could also help me with another issue - I don't know how to set a hyperlink on a "if" block. I could set url on a text in the "if" block, but staying consistent would like to set it on the block itself. Any ideas ?  

Many thanks :)
commented Jun 12, 2019 by plantuml (226,400 points)

It sounds like a good idea.

So with last beta http://beta.plantuml.net/plantuml.jar you can now have :

@startuml
start
[[http://plantuml.com/sequence]]#ff8822:if (?) then (x)
    foo
else (y)
    bar
endif
stop
@enduml

Is this what you are looking for ?

commented Jun 18, 2019 by Sarunas
Thanks very much plantuml ! That's exactly what I've been looking for.

I tried to install this jar as a PlantUML plug-in for Confluence, but it failed. Any ideas how to get this beta jar as plug-in for Confluence ?
0 votes
answered Dec 5, 2019 by Anders
I have the same problem with a partition label in Activity. Neither of the solutions above works. Link text apparently has to be within the double square brackets since there is no colon expected here.

In general: hyperlinkColor should be handled like fontColor, i.e. it should be definable as a default and the for single items like partition etc.
commented Dec 5, 2019 by plantuml (226,400 points)
Could you post a very basic example that shows the issue ?

Thanks
commented Dec 6, 2019 by Anders

The problem is, HyperlinkColor is global so it overwrites default Fontcolor. When I make the partiton label a link, it will be almost invivible against the background. So I tried to color the partition labels individually but coudn't figure how to do that.

'Demo example: partition labels can be hyperlinked
'*or* colored but not both

@startuml

skinparam HyperlinkColor #White

skinparam Default {
  FontColor #004C5D
}

skinparam Activity {
  FontColor #White
  BackgroundColor #D3637D
}

skinparam Partition {
  BackgroundColor #FDF6E3
}

start
'partition demo {
partition "[[https://google.com/ demo]]" {
  :action1;
  :[[https://google.com/ action2 with link]];
}

stop

@enduml
commented Dec 16, 2019 by Anders
Any advice on this?
...