No Image in Directory Error

0 votes
asked Sep 23 in Question / help by anonymous
I had installed PlantUML recently on a Debian-based operating system with Graphviz installed as well. The installation went without any problems but now I am encountering difficulties trying to execute this source code:

 @startum1
 actor Fool
 boundary Foo2
 control Foo3
 entity Foo4
 database Foo5
 collections Foo6

 Foo1 -> Foo2 : To boundary
 Foo1 -> Foo3 : To control
 Foo1 -> Foo4 : To entity
 Foo1 -> Foo5 : To database
 Foo1 -> Foo6 : To colections
@enduml

I have it in a file named practice.txt, and I run the following command within the directory containing the file: java -jar "/usr/share/plantuml/plantuml.jar" practice.txt (I have the full path stated because an error comes up that plantuml.jar cannot be accessed if the full path is not given). But now it gives me an error message that starts with a warning, stating that no image was found in the current working directory but no other information than that.

I would be much obliged for any assistance in this matter.

1 Answer

0 votes
answered Sep 23 by plantuml (205,520 points)
 
Best answer
There is a typo in @startum1 instead of @startuml

A screenshot of the exact error message would also probably help.

You can also try with the -v flag for verbose.

Tell us if you made any progress!
commented Sep 24 by anonymous
Thank you so much! It looks like it was as simple as a typo in the beginning line. Now it works and outputs to an appropriate image. I haven't tried with -v, but I would need to know where in the syntax to place this command.

But thank you. You have restored my sanity in using PlantUML.
...