how to set PLANTUML_LIMIT_SIZE when running intellij idea plugin

+1 vote
asked Nov 20, 2019 in Question / help by Keith
I'm using PlantUML via the Intellij plugin in mac OSX,  but its limited to the PLANTUML_LIMIT_SIZE default of 4096,  I've been sucessful in adding PLANTUML_LIMIT_SIZE=8192 to the bash serttings so I can render my diagrams fully from the cmd line applet,  but Intellij (I think, because its an app) is stubbornly refusing to recognise the new setting.  I like the plugins autorender & preview functionality and dont want to keep swapping out to terminal to render and then to preview to view them, so really want the pluging to work/accept the new setting.

I guess this is as much of an OSX question as much of a plantUML plugin one,  but is there a way I can either

a) run Intellij in a way that is can read the value in the bash settings file,  or better, be able to set the PLANTUML_LIMIT_SIZE=8192 globally outside of bash, that intellij & the plugin can read.

or

b) set the PLANTUML_LIMIT_SIZE parameter from inside intellij.

cheers

Keith
commented Jan 21 by Rhys
Did you ever have any luck resolving this or getting a response? I'd like to know the same. I've got 600 line sequence diagram that doesn't render the whole diagram when zoomed in so I can't actually review the diagram changes beyond the first ~30 lines as I'm updating it as they're not visible whether zoomed out so the diagram becomes tiny or zoomed in and it only renders the first 30 lines.

I've resorted to not using the PlantUML window and running this command from the terminal instead:

 watch -n60 -x java -DPLANTUML_LIMIT_SIZE=8192 -Xmx1024m -jar $PLANTUML_JAR myuml.puml && open -g -a Preview myuml.png

1 Answer

0 votes
answered Mar 9 by anonymous
I found a bad way to solve this in windows. Open the option ‘Help->Edit custom VM option’and add ‘-DPLANTUML_LIMIT_SIZE=8192’ on the last line. It can be work after restart idea.
...