teoz rendering issues

0 votes
asked Nov 29, 2019 in Bug by alonbl (180 points)
edited Nov 30, 2019 by alonbl

Hello,

I am waiting to use the teoz rendering for oneline activities.

In the meanwhile I tested the feature and found several issues.

The test is build from source of https://github.com/plantuml/plantuml 36c461da (master/tag: v1.2019.12).

Reproduction sequence for two page diagram:

@startuml

'!pragma teoz true

a->b: test
activate b
&b->c: test
activate c
c-->b: test
deactivate c
&b-->a: test
deactivate b

newpage

a->b: test

@enduml

 

1. 1st page: Notice misalignment of arrow to activation and deactivation.

2. 1st page: Notice that the "----" page separation is missing.

2. 2nd page: Notice that the "----" page separation is missing.

3. 2nd page: Notice activations of first page are rendered.

Thanks!

Alon

commented Dec 13, 2019 by alonbl (180 points)

 Please just confirm you acknowledge the bug report or redirect me to the correct channel. Thanks!

commented Dec 13, 2019 by plantuml (223,180 points)
Yes, this is the right channel.

But we have too many work, so you will have to be patient.

Sorry about that !

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:

[Antispam2 Feature: please please wait 1 or 2 minutes (this message will disappear) before pressing the button otherwise it will fail](--------)
To avoid this verification in future, please log in or register.
...