Using the !procedure throwing "Syntax Error?" with official docker image of PlantUML Server

0 votes
asked Apr 21, 2020 in Question / help by anonymous

I have installed on my machine the tomcat container (also tried with jetty) of the PlantUML server

docker run -d -p 8080:8080 plantuml/plantuml-server:tomcat

and now, when opening http://localhost:8080/ and trying the example from your web page for procedure usage (see below), I am getting an error:

[From string (line 2) ]
@startuml
!procedure msg($source, $destination)
Syntax Error?

---

@startuml
!procedure msg($source, $destination)
$source --> $destination
!endprocedure

!procedure init_class($name)
class $name {
$addCommonMethod()
}
!endprocedure

!procedure $addCommonMethod()
  toString()
  hashCode()
!endprocedure


init_class("foo1")
init_class("foo2")
msg("foo1", "foo2")
@enduml
---
commented Jun 10, 2020 by m-
I am getting this same error with local jar v1.2020.06
commented Jun 10, 2020 by The-Lu (17,340 points)

Hello,

Just FYI, 'procedure' comes from the version V1.2020.7  (See ‘procedure’ (from 19 Apr, 2020: Introducing procedure in preprocessor (V1.2020.7))).

(And now we are on V1.2020.12) You can perhaps update your version.

Regards,
Th.

1 Answer

0 votes
answered Apr 21, 2020 by plantuml (247,300 points)
The docker https://hub.docker.com/r/plantuml/plantuml-server/ has just been updated.

It should work better now.

Tell us if it does not !
commented Apr 22, 2020 by anonymous
Yeap, works perfectly! Thanks!
...