skinparam for deployments not working

0 votes
asked Apr 29, 2021 in Bug by chris (1,820 points)

skinparam collection {
LineThickness 10.0
}

collections col0

The line thickness skinparam is not applied (similarly to another bug which was resolved recently using the <style> syntax.

I can't use the <style> syntax as I am using other skinparam controls which are not duplicated for style.

Also, weirdly, if you do:

card card

collections collections

You get single rendering, but 

actor actor

collections collections

Switches to a sequence diagram:

1 Answer

0 votes
answered Apr 29, 2021 by The-Lu (46,280 points)
selected Jul 1, 2021 by chris
 
Best answer

Hello C.,

Yes it seems that BorderThickness or LineThickness is not take account (only BackGroundColor and BorderColor), on skinparam:

@startuml
skinparam collections {
  BackGroundColor palegreen
  BorderColor green
  BorderThickness 5
}

collections col0
card card
@enduml

See also: 

A workaround is to migrate all on style... cheeky

@startuml
<style>
collections {
  BackGroundColor palegreen
  LineColor green
  LineThickness 5
}
</style>
collections col0
card card
@enduml

Or just mix skinparam and style...wink

@startuml
<style>
collections {
  LineThickness 5
}
</style>
skinparam collections {
  BackGroundColor palegreen
  BorderColor green
}
collections col0
card card
@enduml

Then for:

Also, weirdly, if you do:

card card
collections collections

You get single rendering, but 

actor actor
collections collections

Switches to a sequence diagram

It is normal:

  • as card is an element of deployment, with any other element that generates deployment diagram.
  • as actor and collections are both elements for sequence or for deployment, that generates the first (sequence) diagram type.wink

If that can help,
Regards,
Th.

asked Jul 7, 2021 in Bug by The-Lu (46,280 points) Correct FontColor of collections with skinparam
...