Message of Sequence Starting with '=' bugged

0 votes
asked Dec 1, 2021 in Bug by howecn (140 points)
A simple example like below:

@startuml
Bob -> Alice : hello\n=123
@enduml

The "123" will be bold and bigger.

PS: I made a script to generate .puml and did some wrap with long messages by adding '\n' before space ' '. Sometimes, it happen.

3 Answers

+1 vote
answered Dec 1, 2021 by Serge Wenger Work (14,580 points)
selected Dec 2, 2021 by howecn
 
Best answer

You can use Unicode char

commented Dec 2, 2021 by howecn (140 points)
Thank you. This solution saved me.
0 votes
answered Dec 1, 2021 by The-Lu (37,840 points)

Hello H.,

In fact, this is a creole (markup) functionally.

See doc. here:

If that can help,
Regards.

0 votes
answered Dec 7, 2021 by Martin (6,780 points)

An alternative answer.  You just need to make sure the "=" is not the first character on the line, so adding a space in front would be enough to prevent the Heading format being invoked.  But that obviously shifts the text by a character.  So another option is to prefix with some formatting tag, <plain> works well as it adds no extra formatting.  Unfortunately tags only apply to the current line and are ended by a carriage return (\n), so you can't just blindly wrap up all your text, you have to target a particular line:

Bob -> Alice : hello\n<plain>=123</plain>

...