title {{mindmap}} with style not work on new version of plantuml?

0 votes
asked Jan 5 in Question / help by howecn (140 points)
I am using mindmap with doxygen like below:

```

@startuml
title
{{mindmap
<style>
style mindmapDiagram {
  node {
    FontColor #2FA4E7
    LineColor #2FA4E7
    BackGroundColor transparent
  }
  arrow {
    LineColor #2FA4E7
  }
}
</style>

* a
** b
*** c
}}
end title
@enduml

```

The styles work on the plantuml.1.2021.8.jar.

But not work on the plantuml-1.2021.16.jar.

Then , I found I could modify it like this:

```

@startmindmap
<style>
mindmapDiagram {
  node {
    FontColor #2FA4E7
    LineColor #2FA4E7
    BackGroundColor transparent
  }
  arrow {
    LineColor #2FA4E7
  }
}
</style>

* a
** b
*** v
@endmindmap

```

This new mindmap works with plantuml-1.2021.16.jar.

But , doxygen not accepted @startmindmap.

Any other suggest? So that I could use plantuml with doxygen to draw a mindmap with style.

2 Answers

0 votes
answered Jan 5 by plantuml (265,060 points)
selected Jan 6 by howecn
 
Best answer

You can also use:

@startuml
title
{{mindmap
<style>
mindmapDiagram {
  node {
    FontColor #2FA4E7
    LineColor #2FA4E7
    BackGroundColor transparent
  }
  arrow {
    LineColor #2FA4E7
  }
}
</style>

* a
** b
*** c
}}
end title
@enduml

This should work. Tell us if it does not.

0 votes
answered Jan 5 by albert (3,180 points)

You wrote:

But , doxygen not accepted @startmindmap.

Doxygen has, as of version 1.9.2, the possibility to specify a so called engine (in this case mindmap) so one can write:

@startuml{mindmap} though you probably would like to keep the @startmindmap in your code and for this doxygen has the ALIASES settings possibility (to be set in your doxygen configuration file Doxyfile) like:

ALIASES += "startmindmap=@startuml{mindmap}"

See in the doxygen documentation:

https://www.doxygen.nl/manual/commands.html#cmdstartuml

https://www.doxygen.nl/manual/config.html#cfg_aliases

commented Jan 6 by howecn (140 points)
Thank you. I tried this with doxygen 1.9.3. It works.

Ubuntu using an version that too old.
...