Skinparam Shadowing true not working anymore

0 votes
asked Apr 23 in Bug by kirchsth (2,890 points)

In old version the border style was correct shadowed in following sample, but now the shadow is lost:

@startuml
skinparam rectangle {
    shadowing false
}
skinparam rectangle<<webApp>> {
    BackgroundColor #438DD5
    Shadowing<<webApp>> true
}
rectangle "Web Application" <<webApp>> as web_app
@enduml

Thank you and best regards
Helmut

PS.: My generated entry  with double defined  <<webApp>>  looks strange (I don't know why it was used/required last time) but without second <<...>> it is not working too ( skinparam rectangle<<webApp>> { ... Shadowing true ... )

1 Answer

0 votes
answered Apr 24 by The-Lu (44,040 points)
selected May 4 by kirchsth
 
Best answer

Hello K.,

A possible workaround is to migrate to style, as:

@startuml
<style>
rectangle {
    shadowing 0
}
.webApp {
    BackgroundColor #438DD5
    Shadowing 1
}
</style>
rectangle "Web Application" <<webApp>> as web_app
@enduml

If that can help,
Regards.

commented Apr 26 by kirchsth (2,890 points)

Hello T.,

Sorry but styles are not an option (the problem is related to C4-PlantUML stdlib and I cannot change everything to styles. all users would have to use styles too).

@plantuml team. Can you please fix it like https://forum.plantuml.net/15458

Thank you and best regards
Helmut

commented May 4 by plantuml (273,620 points)
This should be fixed in last release.

Tell us if you find other issues!

Thanks.
commented May 4 by kirchsth (2,890 points)
Thank you for the fix, it works in C4-stdlib too
BR
Helmut
...