How to generate xmi via command line?

0 votes
asked Jul 21, 2023 in Bug by DarkStar1 (120 points)

I have am trying to convert and plantUML ERD document to xmi/aml and, as per the instructions on the

I ran the following command:

java -jar ~/plantuml.jar erd-model.puml -txmi  -o conv_tests


and get the following exception:

Exception in thread "main" java.lang.UnsupportedOperationException: XMI_STANDARD
    at net.atmp.ImageBuilder.createUGraphic(ImageBuilder.java:469)
    at net.atmp.ImageBuilder.writeImageInternal(ImageBuilder.java:296)
    at net.atmp.ImageBuilder.write(ImageBuilder.java:256)
    at net.sourceforge.plantuml.UmlDiagram.exportDiagramError(UmlDiagram.java:204)
    at net.sourceforge.plantuml.UmlDiagram.exportDiagramError(UmlDiagram.java:160)
    at net.sourceforge.plantuml.UmlDiagram.exportDiagramNow(UmlDiagram.java:153)
    at net.sourceforge.plantuml.AbstractPSystem.exportDiagram(AbstractPSystem.java:198)
    at net.sourceforge.plantuml.PSystemUtils.exportDiagramsDefault(PSystemUtils.java:207)
    at net.sourceforge.plantuml.PSystemUtils.exportDiagrams(PSystemUtils.java:96)
    at net.sourceforge.plantuml.SourceFileReaderAbstract.getGeneratedImages(SourceFileReaderAbstract.java:190)
    at net.sourceforge.plantuml.Run.manageFileInternal(Run.java:510)
    at net.sourceforge.plantuml.Run.processArgs(Run.java:404)
    at net.sourceforge.plantuml.Run.manageAllFiles(Run.java:371)
    at net.sourceforge.plantuml.Run.main(Run.java:206)

Am I missing something?

commented Jul 21, 2023 by albert (3,520 points)
- which version of plantuml did you use?

- what is in your erd-model.puml?
commented Sep 28, 2023 by DarkStar1 (120 points)

I actually logged the bug on the project's issues page but to answer your question,
It didn't matter what was in my ERD, nothing worked.
I was using version plantuml-1.2023.10.
I also see that another person has come across the same bug/issue.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:

[Antispam2 Feature: please please wait 1 or 2 minutes (this message will disappear) before pressing the button otherwise it will fail](--------)
To avoid this verification in future, please log in or register.
...