Eclipse Plugin Fails Installation in Eclipse Luna (4.4) Standard

0 votes
asked Sep 23, 2014 in Bug by attzonko (120 points)
retagged Sep 24, 2014 by attzonko

Here is the error I get when I try to install the PlantUML Plugin (version 8007) in Eclipse Luna (4.4) 64 bit Windows:

 

An error occurred while collecting items to be installed
session context was:(profile=epp.package.standard, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,net.sf.edevtools.lib.nonui,0.3.0.dev
 
 
I am an eclipse newb so I hope I am not doing something wrong. I went through the exercise to install an older version of Eclipse Juno 4.2 and I managed to install PlantUML Plugin version 8007 just fine.
 
Thanks!
Alex

4 Answers

0 votes
answered Sep 29, 2014 by anonymous
Same error, any solution.
0 votes
answered Sep 29, 2014 by plantuml (244,920 points)
Ok, we will report this to the people who are developping the Eclipse plugin.

Thanks for the report!
commented Oct 8, 2014 by attzonko (120 points)
Thanks for the response. Is there a different place to look for status updates from the people who are developing the Eclipse plugin? Or should we expect an answer here from them?
0 votes
answered Oct 21, 2014 by mogoye (140 points)

I've got an other error dunring an install with Luna or Juno on windows 7 Pro. 

An error occurred while installing the items
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]net.sourceforge.plantuml.eclipse 1.1.8.8008, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
java.net.URISyntaxException: Illegal character in scheme name at index 0: %23C:%5CProgram%20Files%5CJava%5Cjdk1.7.0_67%5Cbin%5Cjavaw.exe
java.net.URISyntaxException: Illegal character in scheme name at index 0: %23C:%5CProgram%20Files%5CJava%5Cjdk1.7.0_67%5Cbin%5Cjavaw.exe
 
 
 
 
commented Oct 21, 2014 by mogoye (140 points)
Do not pay attention to my previous comment.

The problem was due to a comment in eclipse.ini file (starting with #).
This comment does not cause pbm during eclipse starup, but with it, it was impossible to install any plugin.
commented May 1, 2015 by anonymous
Thanks for this post.  I had a line commented in eclipse.ini and I was seeing the below exception when trying to install veloeclipse in Eclipse 4.3.

java.net.URISyntaxException: Illegal character in scheme name at index 0: %23C:/jdk1.6.0_45_64/bin/javaw.exe

 I removed the line and I was able to do the install.
0 votes
answered Nov 1, 2014 by plantuml (244,920 points)
Hello,

We have tested with Luna 4.4, using http://plantuml.sourceforge.net/updatesitejuno/ as updatesite.

This is working fine for us (under Windows 7).

Do you still have the issue ?
commented Nov 17, 2014 by anonymous
edited Nov 17, 2014
Works in OS X 10.10. with Elcipse 4.4.0 (Luna).
Apparently there is a bug in Eclipse, working aound it let PlantUML be installed:
http://stackoverflow.com/questions/6470802/what-to-do-about-eclipses-no-repository-found-containing-error-messages

Here my original comment:

It does not work in OS X 10.10 with Eclipse 4.4.0 (Luna)
either using
http://basar.idi.ntnu.no/svn/tdt4100/anonymous/trunk/updatesite
or using
http://plantuml.sourceforge.net/updatesitejuno/ as updatesite
Leaves me with the error:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.standard, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.aspectj.runtime.source,1.7.0.20120703164200
No repository found containing: osgi.bundle,org.eclipse.contribution.weaving.jdt.source,2.2.0.e37x-RELEASE-20120704-0900
No repository found containing: org.eclipse.update.feature,org.eclipse.contribution.weaving.source,2.2.0.e37x-RELEASE-20120704-0900
No repository found containing: osgi.bundle,org.eclipse.contribution.xref.core.source,2.2.0.e37x-RELEASE-20120704-0900
No repository found containing: org.eclipse.update.feature,org.eclipse.contribution.xref.source,2.2.0.e37x-RELEASE-20120704-0900
No repository found containing: osgi.bundle,org.eclipse.contribution.xref.ui.source,2.2.0.e37x-RELEASE-20120704-0900
...