Is ASCIIMath supported in the Eclipse plugin?

0 votes
asked Dec 2, 2016 in Closed question / help by anonymous
ASCIIMath works beautifully from plantuml.jar, but not from the Eclipse plugin.

I presume this is because of the location of the four files extracted from plantuml-jlatexmath.zip, but, as I'm not a java programmer, I'm struggling to work out what is wrong. Please advise.

Thanks,

--Alan Gillespie

2 Answers

0 votes
answered Dec 2, 2016 by plantuml (252,780 points)
Indeed, we did not integrate it within Eclipse Plugin.
We are going to either integrate it with this Plugin or provide a way for users to do it.

We'll post the solution here when it will be ready.
0 votes
answered Dec 2, 2016 by plantuml (252,780 points)

We've just uploaded a updated of the Eclipse plugin on http://plantuml.sourceforge.net/updatesitejuno/

But we had to keep the same version number (V8051), so upgrading from your already-installed Eclipse would not be that easy.

First, you should test on a fresh install of Eclipse (in some new folder c:\neweclipse)

Run this new eclipse, install the plugin just to check that it works with AsciiMath (we have tested it on our side).

If it works, we can try to upgrade your existing eclipse: try to force a reinstall of the plugin to see if it works there.

Keep us informed!

commented Dec 5, 2016 by anonymous
I tried to install the new plugin, but Eclipse rejected it, with the error message:

An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
Error reading signed content.
Exception in opening zip file: C:\eclipse\plugins\net.sourceforge.plantuml.eclipse_1.1.8.8051.jar

...which seems to suggest a problem with a signature on the file.
commented Dec 5, 2016 by plantuml (252,780 points)
Was it on a fresh and new install of Eclipse ?
commented Dec 5, 2016 by anonymous
It was, but I deleted it and tried again and it installed at the second attempt. I wonder if the issue was our firewall and nothing to do with PlantUML.......

Anyway, once installed it wouldn't display the diagram containing the <math>...</math> at first, but after closing and restarting Eclipse a couple of times it burst into life.

On a number of occasions recently I have seen Neon fail to update the PlantUML view after changes have been made to the file - requiring Eclipse to be closed and restarted to get the changes to be reflected in the graphic. I have no idea whether it is an issue with the PlantUML plugin, or Eclipse itself, or even something else on my PC...

Anyway, it seems to be working now, so thanks for your support. Don't worry with forcing Eclipse to reinstall the plugin - it's just as easy for me to install my other plugins into the new Eclipse and delete the old one.

-Alan Gillespie
...