notes in deployment beta point to the wrong objects?

+1 vote
asked May 4, 2017 in Bug by Bryan (260 points)
The following simple example has the note anchored on the wrong object (the artifact instead of the node).
(It also appears to ignore the "right" instruction, putting the note underneath)
 
@startuml
    frame "CHP" {
        node host2 {
            artifact "some details"
        }
        note right
        should point to host2
        not to the artifact "some details"!
        (why is it below?)
        end note
}
@enduml

1 Answer

0 votes
answered May 4, 2017 by plantuml (211,860 points)

Graphviz/Dot tends to crash when using left/right alignment and package.

So be default we ignore them.

There is a setting that overrides this behaviour, but sometimes, it causes Graphviz to crash (and that's why we disable it by default).

You can try:

@startuml
!pragma horizontalLineBetweenDifferentPackageAllowed
frame "CHP" {
        node host2 {
            artifact "some details"
        }
        note right
        should point to host2
        not to the artifact "some details"!
        (why is it below?)
        end note
}
@enduml

commented May 4, 2017 by Bryan (260 points)
Thanks. That does indeed work in terms of putting the note out to the side, however, its probably more important that it points to the right object which is really the problem here. In this instance I need to be able to point a note at host2 rather than the embedded artifact, and I haven't been able to work that one out.

(However, I can and will use the pragma directive elsewhere ... so that's useful feedback, thanks!)
...