Stop clobbering the extensionless text file by default

0 votes
asked Nov 25, 2012 in Closed bug by anonymous
recategorized Nov 26, 2012 by plantuml
When using PlantUML for the first time, I simply created a file called ‘uml’. I copy-pasted some examples from this site to make sure that it works.

I was greatly confused when I couldn't find an output file. I went back to emacs to check that I did everything fine and I quickly found out that PlantUML decided to clobber my text file.

Questioning my housemate about it, he said that it doesn't happen if your text file has a file extension. Due to lack of better ideas, I gave it a ‘.plantuml’ extension and tried again.

As expected, I got a ‘uml.png’ file in my directory. Any chance to stop the default behaviour from clobbering the files without extensions? It barely seems like the best thing to do, especially considering that PlantUML doesn't seem to care about the original extension anyway (although I'm inexperienced with it and the extension might actually be important for something). Seeing as the default output was a ‘.png’ anyway, I don't see the need to clobber my file.

 

Thanks

1 Answer

0 votes
answered Nov 26, 2012 by plantuml (279,640 points)
 
Best answer
Hello,

Sorry about this : it's a very annoying bug that will be solved in next release.

Regards,
...