Bug: skinparam packageShadowing does't work on stereotyped packages

0 votes
asked Sep 17, 2018 in Bug by Sander

Using plantuml 1.2018.10 and the example below, changing the shadowing of a stereotyped package doesn't influence the appearance of a package in the generated image. This behaviour is in the component diagram. 

I noticed setting shadowing (true/false) is also not working for non-stereotyped elements, e.g. cloud, package, database, but IS working for component.

The example has shadowing disabled for the stereotype <Layout>, but changing all packageShadowing to false and of the stereotype to true doesn't change the end result.

@startuml
skinparam packageShadowing true
skinparam packageShadowing<<Layout>> false

package Package1 {
  component Comp1
}
package Package2 <<Layout>> {
  component Comp2
}
@enduml

1 Answer

0 votes
answered Sep 17, 2018 by plantuml (204,600 points)
commented Sep 20, 2018 by Sander
More or less duplicate, as the example didn't match up to the issue text.
Components in a component-diagram did not respond to Shadowing, e.g.  `skinparam cloudShadowing`, or `skinparam databaseShadowing`.

Fixed in the other issue, see also the comments there.
...