Building Svg with -pipe results in Replacing of SpecialCharacters with '?'

0 votes
asked Apr 15 in Question / help by Herrmel

I have a diagramm i want to generate local wich contain special characters like Ä,ü. When I load a textfile with the textcontent or build the text online on your website it works fine. But when I build it with a pipe the characters turn to '?'. For example I use the following powershellcommand:
Get-Content .\test.txt|java -jar plantuml.jar  -tsvg -pipe|Out-String

I tried a older and the newest version. -Charset didnt help. Couldnt find anything java related. I have to use the pipe because I integrated plantuml in a .net application. I tried a few hours to change every possible encoding of the process result and process input to Utf-8 and couldnt find a solution. Since in Powershell Get-Content .\test.txt prints a text with the special Characters i guess its java or plantuml but i have no clue.
Thank you for your great work^^

1 Answer

0 votes
answered Apr 15 by plantuml (198,780 points)

Maybe you should try  -Dfile.encoding=UTF-8

Tell us if it helps.

commented Apr 29 by Herrmel
Thanks for your quick reply. Sadly it did not work. In the outputcomment Default Encoding is mentioned as Utf-8 now instead of Cp1252 but the result stays the same.
Here is a short example plantuml code btw:
note: Stellt angepasste Datenpunktadressierungen für Geräte oder Gerätefamilien Bereit.