For some reason, dot/GraphViz has crashed.

0 votes
asked Jul 8 in Question / help by anonymous

error message

This error occurs when running

java -jar plantuml.jar test.puml

where test.puml is

@startuml
enum Foo {
    bar1
    bar2
}
enum FooFoo {
    barbar1
}
@enduml
commented Jul 8 by albert (2,900 points)
Please mention your plantuml version and dot version used in text and not by means by a a image. Just use java -Djava.awt.headless=true -jar plantuml.jar  -version for it
commented Jul 8 by anonymous
Okay, here is the output:

PlantUML version 1.2020.15 (Sun Jun 28 13:39:45 CEST 2020)
(GPL source distribution)
Java Runtime: Java(TM) SE Runtime Environment
JVM: Java HotSpot(TM) Client VM
Default Encoding: Cp1252
Language: de
Country: DE

PLANTUML_LIMIT_SIZE: 4096

Dot version: dot - graphviz version 2.44.1 (20200629.0846)
Error: dot generates empty file. Check you dot installation.
commented Jul 8 by albert (2,900 points)

That is interesting, I downloaded the dot version 2.44.1 (20200629.0800) and the plantuml version information gives:

Dot version: dot - graphviz version 2.44.1 (20200629.0800)
Installation seems OK. File generation OK

whilst your installation gives:

Dot version: dot - graphviz version 2.44.1 (20200629.0846)
Error: dot generates empty file. Check you dot installation.

It are not completely the same versions, but looks a bit like something is not installed at your place. Also the plantuml versions are slightly different (I tried PlantUML version 1.2020.14 (Sat Jun 20 16:14:34 CEST 2020) and PlantUML version 1.2020.16beta3 (Unknown compile time)

What does the command dot -v give (command will wait for input, just give ^C)?

Also interesting would be what happens when you create a small  dot file e.g. aa.dot:
digraph G {
  "Welcome" -> "To"
  "To" -> "Web"
  "To" -> "GraphViz!"
}

and run:

dot -T png aa.dot > aa.png

commented Jul 9 by anonymous
moved Jul 9

Thank you for your help!

dot -v does not wait for input, but directly prints:

dot - graphviz version 2.44.1 (20200629.0846)
There is no layout engine support for "dot"
Perhaps "dot -c" needs to be run (with installer's privileges) to register the plugins?

running dot -c gives:

Error: failed to open C:\Program Files\Graphviz 2.44.1\bin\config6 for write.

(the file config6 does not exist)

creating a file aa.dot and running dot -T png aa.dot > aa.png gives:

Format: "png" not recognized. Use one of:

 [The following line is empty]

commented Jul 9 by plantuml (226,800 points)
This means there is an issue with your dot installation.

You have to fix it so that PlantUML could work.
commented Jul 9 by albert (2,900 points)

Which platform are you using?

When using Windows, the following is just for testing:

- in a browser goto https://www2.graphviz.org/Packages/stable/windows/10/msbuild/Release/Win32/

- download the graphviz-2.44.1-win32.zip

- open the downloaded zip file and place the bin directory somewhere on your system

- open a command window and adjust the path with the directory where the above mentioned is (set PATH=<path>/bin;%PATH%)

- run again:

  - dot -v

  - dot -T png aa.dot > aa.png

@plantuml is there a possibility to add the platform used to the version information?

commented Jul 13 by anonymous
I'm using Windows 10.

Thanks for your support!

I ran dot -c as admin, a config6 file was created and now it works. ^^'

1 Answer

0 votes
answered Jul 27 by bryan t
Hi guys I ran my cmd terminal in admin mode and it seemed to solve the problem for me
...