ranksep not working for activity diagram

0 votes
asked Jun 17, 2021 in Question / help by Oliver Rahner
I am trying to use `ranksep` to adjust vertical spacing in my activity diagram, but it does not seem to change anything. The same is true for `nodesep` in horizontal direction.

Is this intentional? A missing feature?

Is there any other way to adjust vertical spacing?
commented Jun 17, 2021 by The-Lu (37,800 points)

Hello O,

FYI, is it intentional: It comes from graphviz. And as Activity diagram does not use graphviz, the parameter is without effect.

Then @PlantUML team, for that, a wanted feature will be:

  • Could you manage Margin on style for Activity Diagram?
@startuml
<style>
activityDiagram {
  activity {
    Padding 5
    Margin 30
  }
}
</style>
:a a a a a a;
:b b b b b b;
:a a a a a a;
@enduml
Padding seems to be OK. But not Margin... 

See also:
Thanks for your works...
If that can help,
Regards,
Th.

1 Answer

0 votes
answered Jun 17, 2021 by The-Lu (37,800 points)
 
Best answer

Hello O,

A possible workaround is to use 'dummy label', as:

@startuml
:a a a a a a;
->\n\n\n\n;
:b b b b b b;
:a a a a a a;
@enduml


If that can help,
Regards,
Th.

asked Jun 28, 2021 in Wanted features by The-Lu (37,800 points) Allow Margin on style for Activity Diagram
...