Beta release !Include errors at Plantuml.com

0 votes
asked Jan 18 in Question / help by rwemerson (120 points)

Hello - I've noticed intermittent rendering issues at http://www.plantuml.com/. Sometimes my diagram renders and sometimes it does not.

When it does not, I get a `Cannot open URL` error related to the C4 `!include` statement. The full error is

PlantUML 1.2024.0 beta2
[From string (line 2) ]
@startuml !include https://raw.githubusercontent.com/plantuml-stdlib/C4-PlantUML/master/C4_Container.puml
Cannot open URL

The thing that caught my eye was that 1.2024.0 beta2 was being used.

Does https://www.plantuml.com use both the latest stable release and sometimes use beta?

2 Answers

+2 votes
answered Jan 18 by kirchsth
selected Jan 18 by rwemerson
 
Best answer
If you need only c4 then you can avoid the url problem. It is already part of Plantuml and you can load it via the standardlib include.

!include <C4/C4_Container.puml>

https://www.plantuml.com/plantuml/uml/ZOz12y8m38Nl_HLrfmcYbnr59jEReAXtgLtGGfQM9ZlitriAEaGKJ--595zUQXOJfUzGDzLbYz012Qk98ujz2thPL8lKQ3o9SGHn7jBeIga3HFPKXYnhT8PdkjYPAs2Hp3w8ysHGRu1jTBagfkf5AUtJVQoUmTx9exyDFq2dWGMwahFyUrqT0Ty3Vqqn8iOuYL03jUdz1m00

Helmut
commented Jan 18 by rwemerson

Very helpful, thank you. I now understand how to do includes from

https://github.com/plantuml/plantuml-stdlib/tree/master. Sincere thanks.


0 votes
answered Jan 27 by plantuml (294,540 points)

This issue is related to the fact that Amazon Web Services is going to start charging for IPv4 addresses.

We don't have a single server behind https://www.plantuml.com; there are multiple servers.

Some servers use IPv4, while others use IPv6. It appears that IPv6 servers are experiencing issues with outbound connections to the internet, which are required for !include.

We need to begin our investigation, so please be patient... :-)

Apologies for any inconvenience!

commented Jan 27 by kirchsth
Thank you for the check
Helmut
...