line in class diagram do not connect

0 votes
asked Jan 18, 2013 in Bug by anonymous
recategorized Jan 25, 2013 by plantuml

It seems that lines in class diagrams are not connected correctly, e.g.:

 

@startuml
 
A -* "*" B
 
@enduml
 
generates
image
In this case the line is too short.  In other cases the lines are too long.  Is this a known issue?
 
Oh the version I am trying this with is:
 
PlantUML version 7950 (Wed Jan 16 19:07:59 CET 2013)
Java(TM) SE Runtime Environment
Java HotSpot(TM) 64-Bit Server VM
1.6.0_37-b06-434-11M3909
Mac OS X

 

1 Answer

0 votes
answered Jan 19, 2013 by plantuml (265,020 points)

Hello,

It's possible that this is caused by an old version of GraphViz (older than 2.28.0)

Which one are your using ? You can use the following diagram to test it:

@startuml
testdot
@enduml

 

commented Jan 19, 2013 by anonymous
Thank you for your answer, unfortunately that does not seem to be it.  The version reported is:

Dot version: dot - graphviz version 2.29.20120805.0445 (20120805.0445)

So, newer than 2.28.  
Is there anything I can do to figure out what is going on?

Note that in the minimal example the line is too short, but in slightly bigger examples (the class box contains lots of text and is wide) the line is too long.
Also it seems to happen only when I put a label next to the line, e.g.
A *- "Label" B  
with label normally "*" or "1"

Kind regards
Wim Oudshoorn
commented Jan 19, 2013 by plantuml (265,020 points)
If you generate your diagram with the -keepfile option :
java -jar plantuml.jar -keepfile bug1.txt
(Where bug1.txt contains your minimal example), this will generate a file named "svek.svg" with your diagram.
Could you send us by mail this svek.svg file and the generated .png image ?
We will investigate about this.

PS: A workaround may be to use *-- arrow instead of *-
A *-- "Label" B
It may help.
commented Apr 6, 2013 by anonymous
Did you ever get the files I send?
...