Failed integrated in WORD 2010 64 bit

0 votes
asked Apr 20, 2017 in To be deleted by anonymous
Dear all,

I want to add PlantUML into WORD 2010 64 bit. Did as all suggestion but still failed with message: "The macro cannot be found or has been disabled because of your Macro security settings". My system is: Windows 7 61 bit, WORD 2010 64 bit. Have you ever fix this? I already check solution about this issue but still failed. I think it belongs to 64bit/32bit compatible. Please check it.

Thank you

1 Answer

0 votes
answered 5 days ago by Tymofiy Tovstyzhenko

Hi

I just fixed it for myself

Environment Win 10 64 bit Word 2010

The reason: https://docs.microsoft.com/en-us/office/vba/language/reference/user-interface-help/the-code-in-this-project-must-be-updated-for-use-on-64-bit-systems

How to fix

1. Disable Plant UML ( remove PlantUML_Template_v32.dotm from %appdata%\Microsoft\Word\STARTUp)

2. Open PlantUML_Template_v32.dotm in MS Word

3.Close pop ups with error

4. Open ribbon View

5. Press Macros->View Macros

6. Select Macro_UML_all

7. Click Edit

8. fix all non-compiled parts

from Private Declare Function to Private Declare PtrSafe Function

I know, this fix is not for all environments, but you can do this as a quick fix

...