UTF-8 encoding fails when uml includes salt

0 votes
asked Apr 5 in Bug by anonymous
Plantuml SVG output file is wrongly-encoded in certain case.

- Activity Diagram including salt diagram
- Salt includes Japanese(UTF-8)
- with "-tsvg"  and "-charset UTF-8" option

note that png output has no error.
LANG variable is set to ja_JP.UTF-8

Thanks
commented Apr 5 by albert (2,580 points)
Please show a small example code so it is easier to see what went wrong.
Also specify the version of plantuml you are using (java -Djava.awt.headless=true -jar plantuml.jar  -version)
Check also against the latest beta (http://beta.plantuml.net/plantuml.jar) when not already using it.
commented Apr 11 by anonymous
Thank you for the response.

PlantUML version is 1.2019.04 and latest beta won't solve the problem.
Here are some example codes.

Sample1: no problem

@startuml
(*) --> "{{
salt
{+
^test^
}
}}"
@enduml

Sample2: no problem
@startuml
(*) --> "{{
salt
{+
^てすと^
}
}}"
@enduml

Sample3 : invalid svg output
@startuml
(*) --> "{{
salt
{+
^テスト^
}
}}"
@enduml
commented Apr 12 by plantuml (208,860 points)
Your last example (sample3) is working on the online server.
http://www.plantuml.com/plantuml/svg/SoWkIImgAStDuTBGqbJGrRLJKAgkvYfEp2dXgjRcYdlStFQuQUVZveuuhbgksbebBeVKl1IWQW00

Can you tell us if it's working for you there ? Thanks!

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:

[Antispam2 Feature: please please wait 1 or 2 minutes (this message will disappear) before pressing the button otherwise it will fail](--------)
To avoid this verification in future, please log in or register.
...