Multiple messages at the same height

0 votes
asked Apr 1, 2017 in Wanted features by anonymous
retagged Apr 2, 2017 by plantuml

I'm trying to add notes and messages to a sequence diagram and I'd like to specify a verticle spacing of 0px between two messages. 

@startuml

participant A

participant B

participant C

note over A: "State: Initial"

||0||

note over B: "State: Initial"

||0||

note over C: "State: Initial"

 

A -> B: Send Message

||0||

C -> B: Another Simultaneous Message

@enduml

participant B

1 Answer

0 votes
answered Apr 2, 2017 by plantuml (279,640 points)

There is an alpha feature that you may use (see http://plantuml.com/teoz )

However, work is still in progress here, so there might be some bugs...

@startuml
!pragma teoz true
participant A
participant B
participant C

note over A: "State: Initial"
/ note over B: "State: Initial"
/ note over C: "State: Initial"

A -> B: Send Message
& C -> B: Another Simultaneous Message
@enduml

commented Apr 2, 2017 by PeterBakker (280 points)
I got strange errors when I use TEOZ in a quite complicated sequence diagram. Is it possible to build the & feature in the default engine?

BTW my sequence diagram contain sensitive info so I can't share it, but I will try to find out what causes the problem(s)
commented Apr 3, 2017 by PeterBakker (280 points)
Perhaps my problems with the TEOZ engine are caused by the Visual Studio Code editor plugin I'm using. With the above example I get these errors:

Error found in diagram TEOZ@3-16
OtherTile net.sourceforge.plantuml.sequencediagram.teoz.NotesTile@157d90a
OtherTile net.sourceforge.plantuml.sequencediagram.teoz.NotesTile@157d90a
commented Apr 3, 2017 by plantuml (279,640 points)
That's some debug information we print on the console.
Does it prevent the diagram from working ?
commented Apr 4, 2017 by PeterBakker (280 points)
With the Word plugin the diagram show fine but the Visual Studio Code extension can't handle the debug information. It does shows the diagram very small with the debug info above it and I can't export the diagram to a file.

Would it be possible to make a pragma to disable the debug info, e.g.
!pragma debug false
commented Apr 7, 2017 by plantuml (279,640 points)
Should be ok in last release (V2017.09 and V2017.10)
commented Apr 7, 2017 by PeterBakker (280 points)
I'm not sure what should be ok now so I've tested three things with v2017.10

1. & without !pragma teoz true, this doesn't work
2. / note without !pragma teoz true, this does work!
3. the above example does work now, I don't get debug info anymore in Visual Studio Code but when I change the example into

@startuml
 !pragma teoz true
 participant A
 participant B
 participant C

 note over A: "State: Initial"
 / note over B: "State: Initial"


 A -> B: Send Message
 & C -> B: Another Simultaneous Message
note over C: "State: Initial"
 @enduml

I again get debug info, namely:

Error found in diagram PlantUML@186-199
OtherTile net.sourceforge.plantuml.sequencediagram.teoz.NoteTile@472554
OtherTile net.sourceforge.plantuml.sequencediagram.teoz.NoteTile@472554

This last example  works fine on the PlantUML webserver: http://www.plantuml.com/plantuml/png/ROwn3i8m34JtVCNHWGsnTq1ACp4mvGiii4gareaIXu6l9vKge8BnVCzFjqkPnfcW79_GNDaWKTPm3Ob4ORTns4Pd32Gg8puum_Rel99oZxC43JHr1iSlOFW3D8F5uRHqdkM62vT2OrknXrlljXdkxTs7kKvAmh6MD_Unkr_x2m00
...