How to install plantuml and word plugin in office 365?

0 votes
asked Sep 12, 2018 in Question / help by Mike
The instructions doesn't really match how it looks in office 365.

I have tried, but can't get it to work. Is there anyone that have got it to work in office 365, and can share instructions?
commented Jul 18, 2023 by editor (120 points)
Hi, I use PlantUML on Libreoffice ,thank you for the great tool. Now I tried to also use it on Word 365 on the same machine, same user. The new ribbon appeared, function buttons exist but I couldn't get it work. I get the following error message:

Run time error '5'
Invalid procedure call or argument

Any advice that help me progress would be much-much appreciated.
commented Jun 6 by n/a

Me too, I get following error message:

Run time error '5'

Invalid procedure call or argument

Saving the file to a local disk fixed the issue.

commented Jun 7 by anonymous
I believe to me it was Java 32 bit mismatch back then. To me it is working with minor cosmetic thing: the two icons are all black.

1 Answer

0 votes
answered Nov 13, 2019 by anonymous
edited Nov 13, 2019

Hi Mike,

You have to find the STARTUP directory.


And then follow this:


1- Open Word

2- Alt+F11 (to open macro editor)

3- Ctrl+G (to open immediate window)

4- type: ?Application.StartupPath (to know the instalition path of Word, "c:\users\xxxxx\appdata\local\packages\\localcache\roaming\microsoft\word\startup" in my case) xxxx is hiding my stuff

5- go to that path and follow the second link

Note: .jar file is here

commented Dec 4, 2019 by John

Thanks for the information about finding STARTUP dir.

Even after putting the .jar and .dotm files in STARTUP dir, it doesn't work. When I open Word it gives an error that it cannot open the template file.

I am using the Word2016 template file, since the github website does not have any Word for Office365 specific template file.

Anybody else have the same problem? Any solutions?

I tried opening the same template file in Word 2016 also on a different laptop running Win7, and it still gives the same error - that the file is corrupted or has some problem.

Note that my other Win7 laptop with Word 2016 already has PlantUML plugin for Word and it works fine. I installed in a few years ago, so I don't remember exactly the instructions I followed, but there seems to be a .xml file in the %appdata%\Microsoft dir.
commented Oct 11, 2020 by Ganesh Ramakrishnan

Please disable the Trust Settings in WORD OFFICE 365 and retry

File->Options->Trust Center->Trust Center Settings...-> Enable all Macros