Error: PlantUML and Graphviz 2.45

0 votes
asked May 26, 2020 in Bug by Hammer4All

Trying to generate the following:



java -jar plantuml.jar SD.txt

and get the error:


I have tried to find an older version of Graphviz (, i.e. one of the tested and preferably version 2.38, but I can not find it on (link above) for download?

I changed text to (example from plantuml page):

(First usecase)
(Another usecase) as (UC2)
usecase UC3
usecase (Last\nusecase) as UC4

and get:


Please help out!



commented May 26, 2020 by albert (3,540 points)
Would be nice when we could see the error messages, now it is a a bit of guess / crystal ball work.

- which version of plantuml are you using?

- which version of dot do you have installed?

- which platform are you running on?

When running in the plantuml webservice it all looks OK:

2 Answers

0 votes
answered May 26, 2020 by Hammer4all
Hi, seems like my pictures disappeared in my post. Plant UML version is 1.2020.10.

But I solved it by uninstall the Graphviz 2.45 with its windows uninstaller and instead take the zip file from git and just unzip it and add the environment variable, then it worked.

With this said it seems like the windows installer for Graphviz isn't functional.
0 votes
answered May 26, 2020 by Hammer4all
Hmmm, it also looks like the zip includes 2.39 and not 2.44 of Graphviz as stated? And I'm also pretty sure the windows installer installed 2.45 and not 2.44 as stated in git when download?!

Check the listed items under "Stable 2.44 Windows install packages" link at